Il vaut mieux parfois ne pas se précipiter

J’ai toujours en mémoire cette anecdote que l’on m’a racontée un jour.

Un touriste était dans le désert marocain, sur une piste, et s’est ensablé. Il a tout essayé pour s’en sortir et n’arrivait pas à ses fins notamment en forçant quelque peu avec les gaz.

Arrive un autochtone à qui le touriste demande de l’aide et qui commence par observer la situation.

Il prend le volant, et par tout petits coups, d’avant en arrière, en prenant son temps, arrive à sortir la Jeep de sa situation inconfortable.

Et là, l’autochtone explique au touriste épaté « vous, les Européens, quand il vous arrive quelque chose, vous voulez toujours foncer pour sortir des problèmes, il faut prendre le temps de réfléchir, parfois de reculer, et y aller pas à pas, et là, peu à peu, souvent, on parvient à nos fins ».

Vous ne vous rendez pas compte du nombre de fois où je me remémore cette anecdote.

Tenez, pas plus tard que jeudi passé.

Nous devions aller sur le Léman, avec Madame K, pour profiter d’un bateau Belle Époque de la CGN qui voguait vers le haut lac.

Je me lève tôt le matin et je vais voir sur le Mac App Store quelles sont les mises à jour disponibles puisqu’un petit 2 était noté sur son icône dans le dock.

Je lance la chose et je vois à peu près ça:

2020-07-27_09-54-46 (1).jpeg

Vous comprendrez que ce n’est pas grand-chose.

Je commence par vérifier ma connexion, puis relancer l’application après l’avoir quittée, toujours pareil.

Je vérifie les services Apple, aucune panne n’est annoncée.

2020-07-27_11-02-22

Je relance mon Mac, toujours rien.

Un petit coup d’Onyx, ça peut toujours servir, même problème.

Pour la forme, un passage du disque à l’excellent utilitaire de MacPaw, CleanMyMac X (à ne surtout pas confondre avec cette saloperie de MacKeeper).

Même fenêtre, désespérante de vide.

Je vais dans les diverses bibliothèques, je jette les préférences.

Rien.

J’installe un nouveau Mac OS 10.15.6 version Combo, toujours pareil.

Là, un peu désespéré, je contacte la hotline d’Apple qui doit me rappeler dans les deux minutes.

Je reçois un avis comme quoi elle l’a fait, mais que je n’étais pas disponible et qu’elle me rappellera dans dix minutes.

Je vérifie mon téléphone pour être sûr d’être atteignable, je le suis, alors pourquoi n’ai-je rien reçu?

Une dizaine de minutes après, je reçois une nouvelle notification m’indiquant que j’étais toujours indisponible et que c’était pour eux la dernière tentative, alors que je l’étais, assurément, et que je n’étais pas sur « ne pas déranger » ou autre finesses de ce genre qui, quand vous êtes en mode « désespoir », vous pourrissent la vie parce que vous ne pensez pas à les désactiver.

Je recontacte Apple et là, je reçois bien leur appel téléphonique.

Un commercial me passe à un technicien qui me prend très gentiment en charge en prenant mon écran en partage après m’avoir expliqué qu’il était désolé de le faire, que je pouvais refuser et tout et tout.

Il me montre un peu partout où je dois aller avec une jolie flèche rouge, il teste ma connexion, et comprend que j’ai déjà essayé plein de choses.

Ce qui est marrant, c’est que dans les préférences système, sous Identifiant Apple, je voyais cela:

2020-07-27_10-09-03

Que j’avais bien un bouton de connexion (le seul truc qui apparaissait) dans le Mac App Store, mais rien ne se passait lorsque j’entrais mon mot de passe que je venais de tester directement sur iCloud.

Le technicien m’explique alors que la seule solution est de repartir à zéro, d’effacer mon Mac et de réinstaller un système tout neuf, de tester si le Mac App Store fonctionnait dans cette toute nouvelle configuration et, si tel était le cas, d’utiliser Time Machine pour retrouver toutes mes données.

Bon…

Ben merde alors que j’ai dit à Madame K.

Je n’allais pas partir sur le lac parce que j’avais un truc trop important à faire, ce qu’elle a parfaitement compris. Je crois qu’elle préférait ne pas m’avoir avec elle que de me voir tendu pendant les 6 heures à venir.

Elle est bien, Madame K.

Elle me connaît bien.

Je lance pour commencer une sauvegarde Time Machine, ce que je n’avais pas fait, à ma grande honte, depuis 14 jours.

Je n’avais pas non plus de sauvegarde Carbon Copy Cloner plus récente puisque cette dernière est basée à l’école et que je n’y suis pas retourné depuis deux semaines.

Évidemment, rien que la préparation de la sauvegarde a pris un temps énorme, d’abord parce que ma dernière sauvegarde, comme je l’ai dit, datait de 14 jours, mais qu’en plus, j’avais mis à jour mon système à partir d’une Combo, temps pendant lequel j’ai voulu aller voir les mises à jour sur mon iPhone.

Écran « en chargement » avec petite roue qui tourne en permanence.

Je lance mon iPad pour voir… tout pareil.

Je lance le Mac App Store sur l’ordinateur dédié à la musique: impossible de voir les icônes dans la fenêtre qui apparaît, exactement comme sur mon Mac (voir première figure).

Idem avec le Mac de Madame K.

Je coupe le wifi sur mon iPhone et profite de la 4G: bing (non, pas celui de Microsoft, sinon, j’aurais mis une majuscule, bing, l’interjection, paf si vous préférez), retour des mises à jour qui s’affichent.

Tout pareil avec l’iPad.

Je fais un partage de connexion sur mon Mac: et voilà mon Mac App Store qui réapparaît:

2020-07-27_10-19-50.jpeg

Je dois juste me reconnecter, ce qui se fait sans le moindre problème.

Madame K allait partir, j’ai dit: « je viens avec », on a fait deux sandwichs à toute bombe, j’ai fait mon sac avec mon iPad dedans, et on a couru à la gare où on a chopé le train dix secondes avant qu’il parte.

Le bateau Belle Époque (La Suisse) était en panne, on nous a mis dans un moche bateau, « Le Lavaux », qui pue un peu comme les égouts que c’en est juste écœurant, mais moi, j’étais tranquille.

Par contre, Madame K qui a un amour fou pour les bateaux Belle Époque n’était pas contente du tout.

Et ça, c’est triste.

J’ai tout de même un peu réfléchi pendant cette montée et descente du haut lac.

Si les différents App Store sont en rade chez moi et qu’Apple n’y est pour rien, ce d’autant plus qu’ils fonctionnent parfaitement en partage 4G, c’est que mon fournisseur a dû boutiquer un port ou je ne sais quoi chez lui, ou alors que c’est au niveau de mon routeur que le problème se pose.

En arrivant le soir à la maison, j’ai tiré la prise du routeur, du switch, et de tout le tsoin tsoin (en fait, je n’ai rien arrêté d’autre, je crois, les bornes alimentées par le switch étaient éteintes aussi) et j’ai remis tout ça en ordre après une bonne minute pour être sûr que le tout était bien éteint.

Le problème était toujours présent après redémarrage de tout ce matériel, y compris des bornes.

Je ne me suis pas énervé, c’est fou ce que je progresse avec l’âge venant (ou déjà là), je m’étonne parfois moi-même.

Je me suis dit que j’allais contacter mon excellent fournisseur, à savoir SEFA le lendemain.

Une fois debout, j’ai fait une petite vérification avant de prendre le téléphone, et heureusement que je l’ai faite, parce que tout était rentré dans l’ordre.

Quand je me dis que si Time Machine ne m’avait pas forcé à prendre du temps, j’aurais dû repartir de zéro avec tout de même tellement de trucs à remettre en ordre ensuite, tellement de numéros de série à entrer, et cela malgré les gros efforts qu’il fait (Time Machine donc) pour nous faciliter la tâche, je pense, donc, une fois encore, à cette anecdote des Européens qui veulent toujours s’en sortir en fonçant.

Petite remarque encore, et cette fois pour Apple.

Je crois savoir que les techniciens en ligne font ce qu’ils peuvent pour nous sortir de la gonfle tant que ça reste un problème de surface (non, pas celle de Microsoft, sinon, j’aurais mis une majuscule, et puis ils ne nous dépannent pas sur cette machine chez Apple), mais que, très vite, ils nous proposent une réinitialisation de la machine.

Alors, réfléchissons encore un peu avant de suivre leurs conseils.

C’est le mien (de conseil) de ce jour.